τρέχει ρουμπίνι 1.8.7 στο λιμενεργάτης

ψήφοι
-1

Έχω κληρονομήσει ένα πολύ παλιό app, που χτίστηκε χρησιμοποιώντας Ruby 1.8.7 με postgres και εγώ προσπαθώ να δημιουργήσει μια εικόνα λιμενεργάτης για αυτό.

από αυτήν την εικόνα https://hub.docker.com/r/hublogix/minimal-ruby/ έχω τον κωδικό εφαρμογή προστίθεται στην εικόνα.

έτσι και τώρα είμαι μέσα στην εικόνα, μπορώ να δω:

bash-4.3# ls
Capfile    REVISION   Rakefile   app        config     config.ru  db         doc        lib        public     script     test       tmp        vendor
bash-4.3#


bash-4.3# gem install rake
Fetching: rake-12.3.1.gem (100%)
ERROR:  Error installing rake:
        rake requires Ruby version >= 2.0.0.
bash-4.3#

config / environment.rb είναι όπως:

# Be sure to restart your server when you modify this file

# Specifies gem version of Rails to use when vendor/rails is not present
RAILS_GEM_VERSION = '2.3.16' unless defined? RAILS_GEM_VERSION

APP_NAME = App name

# Bootstrap the Rails environment, frameworks, and default configuration
require File.join(File.dirname(__FILE__), 'boot')

Rails::Initializer.run do |config|

  config.gem inherited_resources,
    :source => http://gemcutter.org,
    :version => 1.0.1

  config.gem has_scope,
    :lib    => has_scope,
    :source => 'http://gemcutter.org',
    :version => 0.4.1

  config.gem haml

  config.gem will_paginate, 
    :lib    => will_paginate,
    :source => http://gemcutter.org

  config.gem searchlogic,
    :lib     => searchlogic,
    :source  => http://gemcutter.org,
    :version => 2.4.11

  config.gem paperclip,
    :lib     => paperclip,
    :source  => http://gemcutter.org,
    :version => 2.3.1.1

  config.gem clearance,
    :lib     => clearance,
    :source  => http://gemcutter.org,
    :version => 0.8.8

  config.gem rsl-stringex,
    :lib     => stringex,
    :source  => http://gems.github.com,
    :version => 1.0.3

  config.gem 'formtastic',
    :lib     => formtastic,
    :version => 0.9.7

  config.gem acts_as_audited,
    :lib     => acts_as_audited,
    :version => 1.1.0

  config.gem prawn,
    :version => 0.8.4

  config.gem htmlentities,
    :version => 4.2.0

  config.gem emap_single_sign_on

  config.gem rmagick,
    :lib => RMagick

  config.load_paths += %W( #{Rails.root}/app/mailers #{Rails.root}/app/observers #{Rails.root}/app/sweepers )
  config.load_paths += %W( #{Rails.root}/app/presenters #{Rails.root}/app/reports)

  config.frameworks -= [ :active_resource ]

  # config.active_record.observers = :name

  config.time_zone = 'UTC'

end

GOOGLE_ANALYTICS_TRACKING_CODE = 

και όταν προσπαθώ να το τρέξει παίρνω αυτό το λάθος από το δοχείο:

/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:900:in `report_activate_error': Could not find RubyGem rack (~> 1.1.0) (Gem::LoadError)
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:248:in `activate'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:1276:in `gem'
        from /usr/src/vendor/rails/actionpack/lib/action_controller.rb:34
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
        from /usr/src/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in `require'
        from /usr/src/vendor/rails/activesupport/lib/active_support/dependencies.rb:547:in `new_constants_in'
        from /usr/src/vendor/rails/activesupport/lib/active_support/dependencies.rb:182:in `require'
        from /usr/src/vendor/rails/railties/lib/commands/server.rb:2
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
        from ./script/server:3

depandanices λίστα:

actionmailer (2.3.17)
actionpack (2.3.17)
activerecord (2.3.17)
activeresource (2.3.17)
activesupport (2.3.17)
andre-geokit (1.2.5)
backup (3.0.25)
builder (3.2.2)
bundler (1.5.3)
excon (0.31.0)
fastercsv (1.5.5, 1.5.4)
formatador (0.2.4)
geocoder (1.1.9)
haml (4.0.5, 2.0.9)
json (1.8.1)
mislav-will_paginate (2.3.11)
multi_json (1.9.0)
mysql (2.9.1, 2.8.1)
newrelic_rpm (3.7.3.204)
nokogiri (1.4.2, 1.4.1)
open4 (1.3.3)
puma (2.8.1)
rack (1.1.6, 1.1.0)
rails (2.3.17)
rake (10.1.1)
rdoc (4.1.1)
RedCloth (4.2.9)
right_aws (3.1.0)
right_http_connection (1.4.0)
rmagick (2.13.3, 2.13.2)
rubyist-aasm (2.0.5)
stringex (1.2.0)
thor (0.15.4)
thoughtbot-paperclip (2.2.9.2)
tilt (2.0.0)

Έχω το φάκελο πωλητής που έχει όλες τις εξαρτήσεις, αλλά είμαι σαφής ως προς το τι άλλο πρέπει να κάνω για να εγκαταστήσετε το βασικό σύστημα στην λιμενεργάτης;

οποιαδήποτε συμβουλή για το πώς να πάρει αυτό το app τρέχει στο λιμενεργάτης ή να το πάρετε για να χτίσει;

Δημοσιεύθηκε 27/11/2018 στις 17:40
πηγή χρήστη
Σε άλλες γλώσσες...                            


1 απαντήσεις

ψήφοι
1

Όταν εγκαθιστάτε το rakeστολίδι χειροκίνητα gem install rakeτότε gem tries to install the latest version. But the latest version ofrake` δεν υποστηρίζει την παλιά έκδοση της Ruby πια. Αντ 'αυτού, θα πρέπει να επιλέξετε μια έκδοση που εξακολουθεί να λειτουργεί με Ruby 1.8.7

Αλλά αυτό είναι μόνο ένα μέρος του προβλήματος. Το πρόβλημά σας είναι ότι θα πρέπει να εγκαταστήσετε όλες τις εξαρτήσεις της εφαρμογής σας, χωρίς οποιαδήποτε πληροφορία τι εξαρτήσεις αίτησή σας θα μπορούσε να έχει.

Από το Ruby on Rails 3.0 bundlerχρησιμοποιείται για τη διαχείριση των εξαρτήσεων. Και εγώ προτείνω ιδιαίτερα να ξεκινήσετε τον καθορισμό το πρόβλημά σας με την προσθήκη bundlerκαι Gemfileτην εφαρμογή σας .

Να θυμάστε ότι έχετε μόνο πολύ περιορισμένες πληροφορίες τις εξαρτήσεις μπορεί να έχει η εφαρμογή σας. Γνωρίζετε ότι χτίστηκε κατά Ruby 1.8.7 που κυκλοφόρησε στα μέσα του 2008. Ως εκ τούτου υποθέτω ότι η αίτησή σας χτίστηκε 2008-2010 (μετά το 2010 ο κύριος του έργου θα μπορούσε πιθανώς να χρησιμοποιηθεί Ruby 1.9.x).

Οι up-to-ενημερωμένες εκδόσεις του rakeήταν ~> 0.8.3εκείνη τη στιγμή (βλέπε rakeεκδόσεις ). Επιπλέον, υποθέτω ότι η εφαρμογή σας χρησιμοποιεί Ruby on Rails 2.x(βλέπε railsεκδόσεις ). Σε <3.0εφαρμογή Rails συνήθως μπορείτε να βρείτε την έκδοση Rails στη config/environment.rbανατεθεί RAILS_GEM_VERSION. Υποθέτω ότι είναι 2.3.5. Δημιουργήστε ένα Gemfileμε αυτές τις πληροφορίες στη ρίζα της αίτησής σας:

source 'https://rubygems.org'

gem 'rails', '2.3.5'
gem 'rake', '~> 0.8.7'

Τοποθετήστε αυτά τα πετράδια από τη λειτουργία bundle installκαι προσπαθήστε να ανοίξετε την κονσόλα κάγκελα ή για να ξεκινήσει το διακομιστή εφαρμογών. Αυτό είναι πολύ πιθανόν δεν θα λειτουργήσει και θα χρειαστεί να προσθέσετε περισσότερα πετράδια ως εξαρτήσεις για σας Gemfile.

Υποθέτω ότι θα πρέπει να προσθέσετε τα παρακάτω:

gem 'rack', '~> 0.9.0'
gem 'mysql', '2.8.1'

Κοιτάξτε προσεκτικά τα μηνύματα λάθους, αν Ruby - για παράδειγμα - παραπονιέται για ένα χαμένο κόσμημα με το όνομα fooστη συνέχεια να εξετάσουμε σε RubyGems ποια έκδοση του fooστολίδι ήταν διαθέσιμο γύρω από την περίοδο 2008-2010 και να προσθέσετε gem 'foo', '<version number>'σε σας Gemfileκαι τρέξτε bundle installξανά.

Δεν είναι εύκολο να βρει όλες τις απαιτούμενες εξαρτήσεις με αυτόν τον τρόπο και είναι ακόμα πιο δύσκολο να βρεθεί ένα σύνολο εργασίας των ειδικών εκδόσεων. Αλλά χωρίς περαιτέρω πληροφορίες είναι IMHO ο καλύτερος τρόπος για να ξεκινήσετε. Καλή τύχη!

Απαντήθηκε 28/11/2018 στις 07:53
πηγή χρήστη

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more